(a b (c |d) e f)

C-M-n works as I would expect, producing this:

(a b (c d)| e f)

But if I break the line after the (c d) like so…

(a b (c |d)
     e f)

The same C-M-n does absolutely nothing. Interestingly, the command works as expected if I insert an end of line space just after (c d). Given that the whole point of paredit is to edit syntax trees rather than text, I don't see how the insertion of a newline should have any impact on the behavior of paredit-forward-up.

What am I missing?

  • I can't replicate this problem (in Emacs 24.5 with paredit-version 25). – phils Sep 26 '16 at 1:01
  • @phils: Where does point move for you? What version of emacs and paredit? I'm using paredit 25beta in emacs 24.5.1. – BPS Sep 26 '16 at 1:07
  • @phils: Ah! I think I may have figured out the problem: I'm using evil-mode. When I disabled evil-mode, the issue went away. – BPS Sep 26 '16 at 1:11
  • Consider reporting the behavior as an Evil bug or needed enhancement, if you think it appropriate. – Drew Sep 26 '16 at 1:34
  • @Drew: Ok. I notice there's an evil-paredit package, so perhaps I should be using that in lieu of plain paredit… – BPS Sep 26 '16 at 1:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.