1

My Shift key is usually working but the combination M-S- is not, and M-S- is sometimes pretty useful in org-mode. It's not just for org-mode, though. I tried describe-key but when I enter S- after M- nothing happens.

For example, M-> (meta+shift+period) no longer activates end-of-buffer.

I'm using Emacs 24.5 and I'm under OSX El capitan

closed as too broad by Gilles Dec 5 '18 at 20:20

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • what did Emacs say, when using this key stroke? – Daniel Hitzel Oct 1 '16 at 17:22
  • Are you using emacs in the terminal or the emacs gui? If it's in the terminal, the terminal will not send all keys to emacs. – amitp Nov 29 '16 at 17:03
  • 1
    Try C-h k (which is describe-key) before the binding. Note that M-S is a modifier, so you will have to type some other character too. – Andrew Swann Mar 31 '17 at 7:08
  • Are you trying to bind a M-S-<lower-case-letter> sequence? If so, this would be a duplicate of Why the key binding M-S-t fails while C-S-t works? – phils Jul 25 '18 at 21:51
  • Emacs doesn't receive a key stroke. – Joe Corneli Sep 6 '18 at 10:21
1

In my case, the keypress was being captured by Amethyst, a 3rd party window manager that runs inside of MacOS. I changed the configuration of Amethyst and the keypress went through to Emacs.

  • I have no idea how you found that, but props to you kind sir! – socketwiz Feb 21 at 18:18
0

I looked into the org-mode source code and find the following line:

(org-defkey org-mode-map [(meta shift right)]  'org-shiftmetaright)

By looking at the other functions, I found out the use something like this:

(global-set-key [(meta shift right)] 'foo)

I tried it in my Emacs and it seems to work this way.

0

When it receives an event with the shift modifier and it can't find any corresponding binding in the keymaps, Emacs then tries a second lookup in the keymaps with the shift modifier removed.

So maybe that's simply what you're seeing.

Not the answer you're looking for? Browse other questions tagged or ask your own question.