0

I'm reading the Emacs manual in Info-mode. Some non-ascii characters render as octal escape sequences rather than glyphs. For example, node 23.2 Minor Modes contains the following text:

Electric Quote mode automatically converts quotation marks. For example, it requotes text typed `like this' to text ‘like this’.

When I view it in an info buffer, I see:

Electric Quote mode automatically converts quotation marks. For example, it requotes text typed `like this' to text \342\200\230like this\342\200\231.

If I select this text and write the region to a file, I can open that file and Emacs renders it correctly.

I'm running Emacs in a gui, but I've repro'd everything above in the terminal as well, and both with and without my init file.

What's causing this behavior, and how can I fix it so info buffers render correctly?

  • 1
    If you see this when starting Emacs using emacs -Q (no init file) then please consider reporting it as an Emacs bug: M-x report-emacs-bug. If you do not see it with virgin Emacs the recursively bisect your init file to find the culprit code. – Drew Oct 6 '16 at 15:29
  • What emacs version are you on? – xuhdev Dec 6 '16 at 9:58
  • Are you on OSX, and is your texinfo program 4.8? This sounds like bug#24637. The fix is to upgrade to 4.13 or higher. – npostavs Feb 3 '17 at 14:13
  • @npostavs That is the right bug. I reported it :) . I would upgrade but it sounds like I'd have to force link it, and given how low impact it is, I'm more inclined to let it lay for now. – ivan Feb 3 '17 at 21:26
  • Oh, that's why it seemed so familiar :) I'll add that as an answer for reference. – npostavs Feb 3 '17 at 22:54
1

This is Bug#24637, as explained there, the problem is due to a bug in old versions of Texinfo. It should be solved by upgrading to version 4.13 or higher.

I would upgrade but it sounds like I'd have to force link it

I don't exactly know what "force link" means, but you should be able to do ./configure MAKEINFO=/path/to/new/makeinfo when building emacs without having to override makeinfo in other contexts.

0

Add this to your config file:

(prefer-coding-system 'utf-8)
(set-default-coding-systems 'utf-8)
(set-terminal-coding-system 'utf-8)
(set-keyboard-coding-system 'utf-8)
(setq default-buffer-file-coding-system 'utf-8)

Also, if you run emacs in tmux, add this to tmux config:

set -gq utf8
setw -gq utf8 on
  • Still no luck. Though this changed the default coding system for new files from utf-8-unix to utf-8, running describe-coding in the Info buffer reports Coding system for saving this buffer: t -- raw-text-unix both before and after adding the above settings. – ivan Oct 6 '16 at 12:47
  • 1
    Which font do you use? Does it support UTF-8? – Stepan S Oct 6 '16 at 15:26
  • I use Avenir Next in Info buffers, and it supports utf-8, but I also repro'd this issue without any of my personal config, in which case Emacs is using Menlo. Menlo also supports utf-8 – ivan Oct 7 '16 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.