3

I am using Spacemacs and after using the splitting windows feature, either by splitting horizontally or vertically, Spacemacs always try to balance the split windows.

For example, when pressing C-x 3 twice, I expect something like this:

++++++++++++++++
|      |   |   |
|      |   |   | 
++++++++++++++++

But Spacemacs always produces this:

++++++++++++++++
|    |    |    |
|    |    |    |
++++++++++++++++

Do you know how to disable Spacemacs from doing so?

Thank you very much!

8

Spacemacs sets window-combination-resize to t, which causes Emacs to split windows evenly. You need to add this to user-config:

(setq window-combination-resize nil)
|improve this answer|||||
  • Thank so much for your answer! This is exactly what I am looking for. – Trung Ta Oct 8 '16 at 5:10
  • interestingly, this is the default value in vanilla emacs. That explains why I never had this issue in emacs. – Chakravarthy Raghunandan Oct 8 '16 at 5:41
  • If I eval the code manually it works, but not if I put it in my configuration. Any idea why? – Nisba Nov 1 '18 at 10:51
1

The golden-ratio package does what you want.

|improve this answer|||||
  • Thanks for the suggestion but golden-ratio always shrinks other inactive windows. Is there any other solution instead of using golden-ratio? – Trung Ta Oct 7 '16 at 16:41
  • Have you tried adjusting the width of the windows in golden-ratio ? I'm not sure how(i dont use golden-ratio anymore), but there is a way to adjust so that it splits the windows to a certain ratio other than default. Check their github page for more info – Chakravarthy Raghunandan Oct 7 '16 at 17:10
  • Thanks for your clue. It's good to know about the option of golden-ratio – Trung Ta Oct 8 '16 at 5:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.