1

I've got a script that generates some output. Some parts of the output are cyrillic letters, and they cause my ansi-term to break - I guess they are treated as control characters(they are displayed like \320\272, and this makes me restart the ansi-term hoping it won't happen again(that I skip this part of output). However, this isn't a fix, but a hack.

How can I make these characters appear correctly/not break my con

  • Is it all cyrillic output, or just some that are broken into control characters? If the latter, this could be Emacs Bug#25288. – npostavs Jan 11 '17 at 16:23
2

The \370\272 is Emacs trying to show the character using octal escapes. See the Emacs manual, node Text Display, and see the Elisp manual, node Usual Display.

You can set variable ctl-arrow to t to see the characters displayed otherwise, using face escape-glyph. But if your font does not enable showing those characters as you expect (Cyrillic) then, well, it can't show them that way. In that case, try a different font.

  • Thank you for your answer. I do not really care for these to show up(although that would be nice), the thing I care the most is that they don't break my console. However, I'm using ssh->emacs in console->ansi term, and it looks like my options of changing font are limited. Any ideas how can I achieve this? – MatthewRock Oct 13 '16 at 12:16
  • Sorry. I hope someone else will be able to offer some more help here. – Drew Oct 13 '16 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.