2

I have disabled electric indent mode, as specified here, but when yanking text, indenting is still performed.

I am yanking text into an html buffer, and I do not want any change whatsoever to be applied to the yanked text. I want it as-is, no indentation, no nothing.

How can I achieve this? I am running:

GNU Emacs 24.5.1 (x86_64-pc-linux-gnu, GTK+ Version 3.18.9) of 2016-04-17 on lgw01-04, modified by Debian

3
  • Does it happen in a session started with emacs -q? electric-indent-mode is for indentation as you type, afaik there is no indentation when yanking, by default.
    – T. Verron
    Oct 13, 2016 at 14:47
  • Can't reproduce. What is the major-mode exactly? Oct 13, 2016 at 17:50
  • Some popular Emacs configurations, i.e., prelude, have this feature enabled. Try to reproduce the problem in emacs -Q.
    – cutejumper
    Oct 13, 2016 at 19:41

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.