1

While this answer (How to make auto-completion case sensitive? - ac-ignore-case) works in some cases.

Using evil mode on its own. Adding (setq ac-ignore-case nil) to ~/.emacs doesn't make completion case sensitive. (Pressing Ctrl-N in evil mode).

From looking into it this calls evil-complete-next.

Checked the source but didn't see any options to adjust.

Can this be made to be case sensitive?

2

Evil mode uses dabbrev, to make autocomplete case sensitive, set this in your emacs config.

(setq dabbrev-case-fold-search nil)

See: case-sensitivity of word completion using dabbrev for details.

thanks to @VanLaser for the hint.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.