Emacs 24.5.

Here is init:

;; appointments

(require 'appt)

(appt-activate t) ; I have also tried (appt-activate 1) here as the appt.el documentation says to

; (setq appt-message-warning-time 1) I have messed around with these variables quite a bit and cannot find anything that works, so they are commented out at the moment. 

; (setq appt-display-interval 1) 

I have tried many variants of the following formats in the diary file, which is working appropriately in all other regards:

Oct 19, 2016

3:00pm testing

15:00 testing

I am aware that the appt-message-warning-time default is 12 minutes. I have tried changing that and everything else that I can find in the documentation. I am saving the diary file each time. I have tried forcing an appt check. Nothing works.

What am I doing wrong?


I thought Dieter's answer got it, but it didn't.

Evaluating (appt-activate 1) in my init file did prompt Emacs to display the appointment. Speaking of that, I changed (appt-activate t) to (appt-activate 1) per the documentation instructions.

However, unless I manually evaluate the expression, the appointment will not diplay.

I thought Dieter was correct about the white space around the diary file formatting, but documentation for appt-check actually says the following:

Note: the time must be the first thing in the line in the diary for a warning to be issued. The format of the time can be either 24 hour or am/pm. For example:

            18:00 Dinner

            11:45am Lunch meeting.

Here is my current init for appointments:

;; appointments

(require 'appt)

(appt-activate 1)

(appt-check 1)

(setq appt-message-warning-time 15)

(setq appt-display-interval 1)

The above is not working. What am I doing wrong?


The problem was in my init file.

I have my diary file set for a custom location:

;; Diary

(setq diary-file "E:/emacs/diary/diary")

This part of my init file appeared AFTER the part of my init file that calls for the appointment activations and checks.

Emacs was trying to check as soon as it hit this:

;; appointments

(require 'appt)

(appt-activate 1)

(appt-check 1)

(setq appt-message-warning-time 15)

(setq appt-display-interval 1)

The problem was that there was no diary file in the default location.

Once I manually ran the check, the appointments displayed.

I put the diary location before the appointments part of my init file, and it is working properly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.