1

When starting an older Emacs (23.4, say) for testing, I get an error from package initialisation a certain package is not available for installation. list-packages also shows a failure but with no details.

Starting with --debug-init shows that the error is:

(error "Archive location https://melpa.org/packages/ is not an absolute file name")

What causes this?

1

This misleading error is due to string-matching the URL against "http:" - essentially HTTPS is not supported by package-legacy.el.

Arguably this is also a bug in cask.el (which only uses HTTPS) but I'm not sure if they already dropped support for Emacs 23.

1

In my case, I still had a package.el in my emacs config from when I was using Emacs 23, and even now that I'm on Emacs 24 it was still using the "vendored" package.el. Deleting that file fixed my issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.