Currently I have jsx in my js files but when using web-mode it is only possible to have single quotes or double quotes for html attributes with this setting the web-mode-auto-quote-style setting, e.g:

(setq web-mode-auto-quote-style 2) ; use single quotes

I would like to disable it all together but how is this possible when it only takes 1 or 2 as a value.

1 Answer 1

(setq web-mode-enable-auto-quoting nil)

Add double quotes after the character = in a tag.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.