1

I am starting to use emacs guy (precisely this https://emacsformacosx.com) and I am not always getting monospaced charters as I get in emacs when using terminal. I have tried putting this in my .emacs (found in the web)

;; Only change sectioning colour
(setq font-latex-fontify-sectioning 1.0)
(setq font-latex-fontify-sectioning 'color)
(setq font-latex-slide-title-face 1.0)
;; super-/sub-script on baseline
(setq font-latex-script-display (quote (nil)))
;; Do not change super-/sub-script font
;; Exclude bold/italic from keywords
(setq font-latex-deactivated-keyword-classes
'("italic-command" "bold-command" "italic-declaration" "bold-declaration"))

I got some improvements but as you can see in the images I have not solved my problem yet.

What I expect:

enter image description here

What I get (you can see that "Theoretical introduction" is small and not vertically aligned to other characters). What can I do? enter image description here

How to solve it?

1
  • You are using 2 different fonts in the 2nd screen shot (compare i in \begin{figure} and Theoretical). I suggest you try to find out why this happens. You can use C-u C-x = on those characters to find out which font Emacs is using. Oct 29, 2016 at 17:38

1 Answer 1

1

AucTeX modifies provides a bunch of customizable faces. You can view and edit them with M-x customize-group font-latex-highlighting-faces. Go through that list, and untick the 'height' box on any that have it set.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.