I am using emacs for OSX (GUI, not the terminal). I use desktop-save in order to save my workflow when closing emacs. All works fine except when I use OSX virtual desktop: if I open emacs in "Virtual Desktop 1", I create a new frame, I place it "Virtual Desktop 2", I use desktop-save, I quit emacs and then I open it again, then the two frames will be opened in the current virtual desktop and not the first in "Virtual Desktop 1" and the second in "Virtual desktop 2", as I would like to happen.

In order to avoid ambiguity I insert an image that clarifies what I mean with "Virtual desktop".

macOS 10.12 with 11 virtual desktop, the first two with emacs opened

The image portrays macOS 10.12 with 11 virtual desktop, the first two with emacs opened.

  • 2
    There is nothing inside Emacs (e.g., desktop.el, etc.) that I am aware of to take advantage of OSX virtual desktops. Emacs was not designed to be compatible with all the new features of 10.12. You may wish to consider submitting a feature request for the Emacs team to implement desktop-save abilities that work with OSX -- perhaps someday the feature request will be come a reality. You may wish to consider experimenting yourself with writing up an applescript to achieve your goal, and share it with the community once you work out the details.
    – lawlist
    Oct 29, 2016 at 17:04
  • ok, my post was ambiguous: virtual desktop is a feature available since OSX lion (or even before)
    – Nisba
    Oct 29, 2016 at 17:09

1 Answer 1


It seems there have been some changes in 10.12 with the introduction of the 'tabbed' windows option which can affect emacs. I found that when I created new frames, they were on the same 'virtual desktop' where previously, they were on a different virtual desktop (when doing so in fullscreen mode).

I found that this was because of a new option under the dock preferences. The option has the title/text "Prefer tabs when opening documents" and was set to "In full screen only". Changing this to "Manual" has restored the previous behaviour. Not sure if that will fix your issue, but may be worth giving it a try.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.