0

I recently started using spacemacs/emacs, and encountered the following problem:

When I enable popwin-mode I would expect popup windows to get handled by popwin. However, when I run occur (M-x occur), it seems to not be - the buffer with the occur results always gets opened in another buffer either to the left or right of the current one. And can not be closed with C-g, as advertised.

Having set popwin-window-position to bottom, I would also expect occur to open a new buffer below the current one. But, as I said, it does not.

Could anyone help me fix whatever is the problem here?

  • What is the value of the option popwin:special-display-config? The default value of popwin:special-display-config has an entry (occur-mode :noselect t) which should handle occur-mode. – Tobias Nov 1 '16 at 18:55
1

@Tobias's comment led me to the solution.

popwin has a variable special-display-config which specifies, in various ways, on what buffers it should act on. The spacemacs default configuration does not by default handle occur-mode. I added an entry named *occur* via M-x customize-variable, and now it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.