0

Using Ostro on #IntelMaker #Joule, I've downloaded the earliest version of emacs available from https://ftp.gnu.org/pub/gnu/emacs/, and tried running configure, but it failed with a message that emacs wasn't ported to the platform yet.

root@intel-corei7-64:~/emacs/emacs-21.4# ./configure 
creating cache ./config.cache
checking host system type... x86_64-unknown-linux-gnu
configure: error: Emacs hasn't been ported to `x86_64-unknown-linux-gnu' systems.
Check `etc/MACHINES' for recognized configuration names.
root@intel-corei7-64:~/emacs/emacs-21.4# cd ..

If I just want an emacs-like text editor, and don't have a package manager, what's the quickest way to get an emacs-compatible editor going?

Size-wise, emacs-21.4a.tar.gz is only 19M, but emacs-25.1.tar.gz is already 59M.

What was the earliest version that had support for x86_64?

  • emacswiki.org/emacs/ErsatzEmacs – npostavs Nov 6 '16 at 4:20
  • @npostavs, I've tried compiling mg, but it appears to depend on libbsd, but installing libbsd doesn't seem to make it detect it. – cnst Nov 6 '16 at 4:31
1

It turns out, Emacs is surprisingly fast to build, so, building even the latest version appears to take less time than the time it takes to run the ./configure script!

  • Building the release tarballs is fairly quick because they already include the compiled lisp files. – npostavs Nov 6 '16 at 4:19
0

You can use some lightweight editor like mg as a replacement for emacs.

  • No, mg has too many dependencies on unbranded Linux, and cannot be built easily. – cnst Dec 8 '16 at 22:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.