2

I went to start emacs today and was greeted with this:

WARNING: No org-loaddefs.el file could be found from where org.el is loaded.

followed by

You need to run "make" or "make autoloads" from Org lisp directory

Any idea how I can fix this error?

  • It says you should generate autoload file. After setup load-path, you also need to load org-loaddefs.el via (require 'org-loaddefs) (BTW, there is no need to load any other features). Please follow orgmode.org/manual/Installation.html to install org from git. – xuchunyang Nov 7 '16 at 4:12
  • Did running "make" or "make autoloads" from Org lisp directory make the problem go away, or not? – phils May 6 '18 at 2:19
1

As hinted at by this thread the issue can arise when the org installation is newer than the emacs version which is running.

A simple solution is remove the org package or, if it is marked as "builtin" in the package-list-packages view, remove the entire ~/.emacs.d/elpa/org-20xxxxxx directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.