1

The title pretty much sums it up, I'd like to avoid that the scroll continues when I release the touchpad. Here's my custom variable about the mouse wheel behaviour:

'(mouse-wheel-scroll-amount '(1 ((shift) . 5)))
'(mouse-wheel-progressive-speed nil)

To be honest, I'm not sure whether this is is actually inertia or the scroll operations stack up and get executed with some delay hence causing the effect.

The behaviour is observed with emacs -q as well.

  • 1
    why use the touchpad to scroll. Pressing C-v or M-v should be easier than inconsistent scrolling with touchpad. – Chakravarthy Raghunandan Nov 7 '16 at 18:22
  • Because sometimes I want to scroll just a few lines. – cYrus Nov 7 '16 at 20:22
  • I'm not sure if you can disable insertia, but what you can do is, make the cursor position not change while you scroll – Chakravarthy Raghunandan Nov 8 '16 at 5:40
  • @ChakravarthyRaghunandan why using just terminal? Rely on books and use hands to move next/prev ;-) – test30 Apr 26 '19 at 6:09
0

I finally found a definitive solution for this:

(setq ns-use-mwheel-momentum nil)

Also possibly related is the ns-use-mwheel-acceleration variable.


Tested on macOS Mojave with GNU Emacs 26.1 (build 1, x86_64-apple-darwin14.5.0, NS appkit-1348.17 Version 10.10.5 (Build 14F2511)) of 2018-05-31

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.