1

I'm running GNU Emacs 24.4.1 (x86_64-apple-darwin13.4.0, NS apple-appkit-1265.21) of 2014-10-20 on builder10-9.porkrind.org, the one available form gnuemacsformacosx.com. After upgrading, my modeline was mostly blank, and it seemed that this error was due to something involving powerline. In any case, I decided to switch to smart-mode-line. So I installed the latter package and have attempted to delete powerline by

  1. deleting it from the package list using d, x
  2. deleting all occurrences of expressions containing 'powerline' in my .emacs

However, I am still receiving the following error in my messages when I launch Emacs:

Eager macro-expansion failure: (error "Autoloading failed to define function defpowerline")
Error: (file-error "Cannot open load file" "no such file or directory" "powerline")

I cannot figure out how to track down the cause of this error. I'm most grateful for any help!

  • 1
    Your approach should have worked. Are you absolutely certain you don't have a mention of defpowerline somewhere? – Malabarba Oct 30 '14 at 12:58
  • 4
    Are maybe references in your custom.el? Do you have a .emacs.d directory? Search with ag or ack or grep in all relevant files. – Tom Regner Oct 30 '14 at 12:58
1

deleting it from the package list using d, x

Normally, it should have worked nice. What about reinstall the powerline package by first deleting it in elpa folder and restart emacs?

Also, isn't there a byte compiled file loaded somewhere? You will probably need to recompile it after removing powerline.

I've just found this github issue. Not really the same environment, but I think it could help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.