0

At work I'm connecting to a server that only accepts SFTP connections. I can connect from the command line just fine. I'd like to use TRAMP or Ange-FTP or something similar from within Emacs, but I'm stuck.

When I say C-x C-f /sftp:user@host: I expect to get a prompt for a password but instead I get back Unknown method "sftp" in the echo area.

I'm using the TRAMP that came with Emacs, and I notice that tramp-methods does not contain anything for sftp. Do I need to add something there?

  • Have you tried using scp instead of sftp? – Jack Nov 11 '16 at 20:06
  • 1
    Just tried. Saw "Tramp failed to connect. If this happens repeatedly, try M-x tramp-cleanup-this-connection" in the echo area. Went to the *Messages* buffer and found the ssh command that was executing behind the scenes. Copy-pasted that into a terminal, got PTY allocation request failed on channel 1 and shell request failed on channel 1 – purple_arrows Nov 11 '16 at 20:13
  • Sounds like the host has specifically disabled ssh access. The 'scp' method actually uses both ssh and scp to connect to the server (scp for transferring files, ssh for related tasks such as filename completion). – db48x Nov 12 '16 at 11:16
  • Have you tried using scpx: instead of scp:? – Melioratus Nov 21 '16 at 4:55
0

Tramp supports sftp only in conjunction with gvfs. I fear, that this is not available for OS X.

Another possibility could be to use psftp from the PuTTY suite. Although PuTTY is dedicated to MS Windows machines, it might also be available for OS X. I know that it exists for GNU/Linux.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.