0

I've a hard time to make Gnus working properly. I got the following error :

Debugger entered--Lisp error: (void-function nnir-search-engine)

Any idea what is wrong? I precise that I've no problem sending some mails, so the SMTP side is fine.

I can provide the full backtrace error if needed. Thanks.

My config:

I've the following in ~/.gnus.el :

(require 'nnir) 
;; I added this require just in case but does not change anything

(setq gnus-select-method
      '(nnimap "gmail"
           (nnimap-address "imap.gmail.com")
           (nnimap-server-port 993)
           (nnimap-stream ssl)))
               (nnir-search-engine imap)
               (nnimap-authinfo-file "~/.authinfo")))

My .profile :

export EMAIL="my_mail@gmail.com"
export NAME="Rico"
export SMTPSERVER="smtp.gmail.com"

My .authinfo :

machine SMTP.gmail.com login my_mail@gmail.com port 465 password my_pwd
1

Ah. It seems that you have misplaced the (nnir-search-engine imap) (nnimap-authinfo-file "~/.authinfo") part. That should be inside the parens that start at '(nnimp "gmail".

Correct would be:

(setq gnus-select-method
      '(nnimap "gmail"
               (nnimap-address "imap.gmail.com")
               (nnimap-server-port 993)
               (nnimap-stream ssl)
               (nnir-search-enging imap)
               (nnimap-authinfo-file "~/.authinfo")))
;; -- Two too many ))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.