0

(I haven't find any answer in previous topics)

I am using Smart Tab globally, i.e. I have put the following code in my .emacs :

(require 'smart-tab)
(global-smart-tab-mode 1)

I am writing a program in Fortran, and I often need to indent some lines, which, according to smart-tab documentation, is done either by prefixing the smart-tab command (i.e. <tab>) by C-u or by selecting the region to be indented before hitting <tab>.

After some research, I still don't understand why only the "selecting a region" method works for me : to indent just one line, I need to have it selected, but C-u <tab> does not work, and always gives to following message (which I don't understand) :

Symbol's function definition is void: cl-case

Being able to indent any line (and just one line) by using <tab> in a simple command would solve my problem (while keeping smart-tab).

  • 1
    Have you tried adding (require 'cl) to your config? That should help with this, but you shouldn't have any problem with this. Is your version of Emacs up to date? – DoMiNeLa10 Nov 17 '16 at 18:03
  • Adding (require 'cl) to my config file soved the problem ! Thanks a lot DoMiNeLa10 ! – Giuseppe Nov 17 '16 at 18:17
1

As said in the comments on my question, adding (require 'cl) to my config file solved my problem (following DoMiNeLa10's suggestion).

N.B.: I am using Emacs 24.3.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.