3

I am using Emacs with the ein package to edit ipython files. Everything works fine except when I have a line like:

fhandle = raw_input('enter your file name: ')

to prompt for a file name. The ipython subprocess that is running inside Emacs stops responding. (there is a little star at In[] that indicates this).

When I run the same command in the usual jupyter notebook web interface it works fine as usual. (there is a little box where it prompts me for the file name). I am thinking emacs + ein somehow doesn't have this capability?. What am I doing wrong here?. I am using python 2.7.

  • I am not using ein but I have the same behaviour. Have have you solved? – Nisba Feb 23 '18 at 17:37
1

I am using emacs 25.2

In my case I tink that this was the problem https://github.com/syl20bnr/spacemacs/issues/8797

I solved setting up Python 3 and installing python-mode.

Note that in Python 3 raw_input has been replaced by input.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.