I use a lot of embedded latex in my org files with drill mode. It worked fine with org 8, but recently I've upgraded to org 9, and now when I run C-c C-x C-l I'll get this error. My .emacs file contains the following code related with org and latex:

(setq org-latex-create-formula-image-program 'dvipng) 
(setq org-format-latex-options (plist-put org-format-latex-options :scale 1.5))

I'm new to Emacs. What should I do to fix this?

  • Function org-export--get-global-options has not been defined. Perhaps it was replaced by something else in the Org code. Or perhaps it is defined in an Org file that you have not loaded. Look for it in the Org code. If it is not there then compare the current Org code with the last version, to find out what replaced it - and use whatever replaced it.
    – Drew
    Nov 27, 2016 at 18:54

1 Answer 1


The problem is solved. I just added

(require 'ox)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.