1

I've installed ox-reveal package from MELPA with package-install ox-reveal and added in the configuration file the following:

(setq org-reveal-root "http://cdn.jsdelivr.net/reveal.js/3.0.0/")

However, when I try to export a test presentation with C-c C-e I don't see an entry for reveal.

I've tried requiring the package with:

(require 'ox-reveal)
(setq org-reveal-root "http://cdn.jsdelivr.net/reveal.js/3.0.0/")

But that gives me the following error when Emacs starts:

error: Required feature ‘ox-reveal’ was not provided

Is there something I'm missing?

PS: I'm using Emacs on Cygwing and here's the package versions

org                20161118
ox-reveal          20161027.226
  • I can't reproduce this. (require 'ox-reveal) is the only thing I need to get prompt. Just in case, have you tried to restart your Emacs? – Yasushi Shoji Nov 29 '16 at 5:43
  • @YasushiShoji, yes I restarted it multiple times. Is there any additional info I can provide to make the issue reproducible? – RePierre Nov 29 '16 at 7:59
0

Emacs manual states that

If loading the file succeeds but does not provide feature, require signals an error, ‘Required feature feature was not provided’.

The version "20161027.226", which is the version I also have, seems to work fine. So my guess is that you might have two or more version of ox-reveal in your load-path.

What happens if you launch a new Emacs instance and do M-x load-file and give ~/.emacs.d/elpa/ox-reveal-20161027.226/ox-reveal.el at the prompt. And do C-c C-e? If this works, the one you just loaded and the one (require 'ox-reveal) loaded is different.

Not sure how you write ~/ on Cygwin, though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.