11

After setting dired-auto-revert-buffer to t, even when I'm working on a buffer of file that may produce some results, the message keep printing if there is a dired buffer behind current buffer. This is really annoying. How can I completely disable it? Thanks!

13

Customize option auto-revert-verbose to nil. C-h v tells you this:

auto-revert-verbose is a variable defined in autorevert.el.

Its value is t

Documentation:

When nil, Auto-Revert Mode does not generate any messages.

When non-nil, a message is generated whenever a file is reverted.

You can customize this variable.

It's kind of a shame that the doc of auto-revert-mode does not mention this option. Neither the doc string (C-h v) nor the Emacs manual (node Reverting) mentions it.

(I filed Emacs bug #25162, as an enhancement request to mention it.)

  • Thanks, this seems to work. I looked into dired, but find no hints of it. I didn't known this is an auto revert mode issue. – stackunderflow Dec 11 '16 at 3:39
  • You could presumably set this buffer-local in a dired hook if you still want the message when visiting a file. – glucas Dec 11 '16 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.