5

The key combination is used in Emacs to mark from the point to the end of the line (navigation with shift selection), but a box is overriding that making it unusable.

I have been working in another station with Fedora 24, and the problem doesn't show, so it seems to be derived from Fedora 25 (the version of Emacs is the same in both stations).


Here is a sample of the box (right after the box appears it has the @ symbol):

enter image description here


Another sample, once the box is showing, if I type anything: enter image description here


Alternatively, once the box is showing, if I do ctrl+x then I get:

enter image description here


In order to solve the problem, it is needed to know what the box is, and I think I prove that right, because unsuccessfully spent many hours "googling" for something I don't know how to name or describe, the GUI doesn't show a gloss, apologies for my ignorance.

  • 2
    Check in your system settings for something like “input method”. What makes the box disappear and what doesn't? In particular, does it disappear if you switch to another application? Try to figure out what it is: in a terminal, run wmctrl -l while the box is not shown and while it is shown (you can run sleep 3; wmctrl -l to show the window list after 3 seconds), and look for an added line. – Gilles Dec 13 '16 at 21:30
  • I believe this is not really emacs-related. Since that is a GTK+ build, you're probably activating some GTK shortcut. – YoungFrog Dec 14 '16 at 8:15
  • @Gilles I checked "input method" in my system settings, but it is just a fresh installed Fedora 25, I have not changed anything about that, and I searched but it doesn't seem to have that settings in the GNOME GUI, but I am looking into it, I should find it with the console. I don't know what makes it appear/disappear, that's precisely one of problems I have to track the origin of the issue. I will try wmctrl, I am waiting to have the problem show again, it should today. I will give update soon. – mikl Dec 14 '16 at 15:25
  • @YoungFrog I am also afraid it isn't, but I am not sure, because the problem goes away as soon as I don't use Emacs, maybe it is only related to the combination of Emacs and other software. On the other hand I have not had responses anywhere else, nor have been able to find any documentation in the internet. – mikl Dec 14 '16 at 15:28
  • 1
    It would be better to separate your answer from your question. The new edits make the question very confusing. Feel free to answer your own question, and then mark the answer as accepted. – nispio Dec 19 '16 at 15:28
1

The box corresponds to a new input method introduced in Fedora 25 for typing emojis (https://fedoramagazine.org/using-favorite-emoji-fedora-25/), and comes from ibus. The functionality is activated in system startup by default.

I couldn't find a way to change the ibus shortcut or to disable it. I tryed uninstalling ibus or stopping the service but this causes other problems.

The documentation says (or suggests) that the release does not include a mechanism to disable the feature: https://fedoraproject.org/wiki/Changes/IBus_Emoji_Typing.

A trick to temporarily disable the box appearance is to close session and start it again. That's the only workaround I have found so far (this "trick" is actually a bug that was fixed in subsequent versions of Fedora).

A feature request has been made to customize the ibus functionality: https://bugzilla.redhat.com/show_bug.cgi?id=1405629.


UPDATE

The issue has been solved by Fedora developers. The solution works in Fedora 26 onwards, it is as follows:

$ ibus-setup

Then the ibus setup panel will show, here you can change Ctrl+Shift+e to something else.

I applied this solution in Fedora 28, so I confirm that it works in this version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.