4

I am using the Tomorrow-Eighties color theme from the color-theme-sanityinc-tomorrow package. Unfortunately when using Helm, not all of the correct colors seem to be applied. I've had an interaction with the developer of the theme, and he's not seeing the same thing I'm seeing, so I'm worried it's something unique to my setup.

The screenshot below shows what my helm-find-files buffer looks like. As you can see, the background color for directories gets messed up, and the current line highlight is also ugly, and not typical for this theme. What do I need to change to get helm to use the theme defaults for background colors and the current selection?

Current line and directory background colors are incorrect

  • Have you tried loading just Helm and the theme in your emacs init? – Kaushal Modi Nov 1 '14 at 3:52
  • 1
    Try customizing those specific faces. M-x customize-face RET helm-ff-directory, helm-selection and helm-source-header. I had the same problem and I had to load the theme with load. But I recently upgraded to emacs 24.4 and the problem magically disappeared. – caisah Nov 1 '14 at 19:20
  • 1
    @caisah Maybe 24.4 will hold the secret answers for me. – Ryan Nov 1 '14 at 20:39
  • @caisah 24.4 seems to have been the trick. Updated today and the issue is gone. Want to make it an answer so I can mark it and give credit where credit is due? – Ryan Nov 3 '14 at 17:29
  • 1
    @Ryan Glad to hear it worked. I don't want to make it an answer because it's not a solid solution... There has to be a bug somewhere and hopefully someone will find it :) – caisah Nov 3 '14 at 19:20
2

I don't see such colours mismatches in my setup, I also use Helm.

  • Check whether or not you have multiple themes applied M-x disable-theme.
  • Check your init file for set-face-background, set-face-foreground, set-face-attribute declarations and remove them.
  • Verify again how you are loading the theme: (load-theme 'somename t)
  • See whether or not an empty init file with just helm-mode enabled and your selected theme looks fine.

I guess it's time to post some of your init file then. Are you using the theme as a MELPA package or another mechanism?

Below is a screenshot on OSX within a tmux session (no fancy tricks)

enter image description here

  • I must just be unlucky. I've done all of that, and still it looks nasty. – Ryan Nov 1 '14 at 0:56
  • Just wanted to say +1 for this, I had no idea that multiple themes could be active at once ... reading your post revealed several issues with my setup that I was able to correct. Thanks! – Hagmonk Sep 15 '15 at 0:34
  • But while I'm at it, how do you recommend setting the default fonts? I was using set-face-attribute before that. Perhaps it's safe to use just for fonts? – Hagmonk Sep 15 '15 at 0:35
2

Upgrading from Emacs 24.3 to 24.4 corrected the issue.

0

I use moe-theme, it's pretty like your color-theme-sanityinc-tomorrow here. There is no difference with the color of files and directories, and the color of current line is nice as well.

NOTE: I customize the color of the mode line by myself.

Screenshot

  • I don't really want to switch themes, though. Thank you for the suggestion, but I'd rather fix what's wrong with the one I have. – Ryan Nov 1 '14 at 0:57
  • @Ryan Check out helm-buffer-directory and helm-buffer-file in helm-buffers.el, and helm-selection in helm.el and M-x customize-face => helm-buffer-file or helm-buffer-directory or helm-selection to set them, and M-x customize-group => helm for more. – CodyChan Nov 1 '14 at 1:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.