0

I get this error message when trying to configure CEDET:

Symbol's function definition is void: ´cedet-gnu-global-version-check´

This is my elisp code:

(require 'auto-complete)    ; start auto-complete with emacs
(require 'auto-complete-config) ; do default config for auto-complete
(require 'yasnippet)        ; start yasnippet with emacs
(require 'cc-mode)
(require 'semantic)
(require 'semantic/ia)
(require 'semantic/bovine/gcc)

;; Enables global support for Semanticdb
(global-semanticdb-minor-mode 1)

;; Activates automatic parsing of source code in the idle time;
(global-semantic-idle-scheduler-mode 1)

;; Activates highlighting of first line for current tag (function, class, etc.);
(global-semantic-stickyfunc-mode 1)

;; Activates displaying of possible name completions in the idle
;; time. Requires that global-semantic-idle-scheduler-mode was enabled;
(global-semantic-idle-completions-mode 1)

(setq-mode-local c-mode semanticdb-find-default-throttle
             '(project unloaded system recursive))

(semantic-mode 1)

(when (cedet-gnu-global-version-check t)
  (semanticdb-enable-gnu-global-databases 'c-mode)
  (semanticdb-enable-gnu-global-databases 'c++-mode))

Did I forget something? How do I find the function in question?

  • Yes. You did not load the library that defines function cedet-gnu-global-version-check. – Drew Dec 19 '16 at 2:04
  • Yes, I supposed this. But, how can I find what library provides it? – Daniele Dec 19 '16 at 13:02
  • Search the CEDET source code (or other source code, if you don't find it there). If you have grep, use that (you can even use it inside Emacs: M-x grep). Otherwise, use whatever file-searching tool your platform offers. – Drew Dec 19 '16 at 14:51
1

The cedet-gnu-global-version-check is defined within the cedet-global.el file, adding the (require 'cedet-global) statement solved my issue.

  • +1 for solving your own problem and posting the solution. Hopefully it will help other people with a similar problem later on! – Dan Dec 19 '16 at 22:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.