0

enter image description here

As in the picture, when I editing python file, there are two completions. Why is that? Thank you very much.

Following are my init.el related to elpy and completion:

(elpy-enable)
;;(setq elpy-rpc-backend "jedi")
;;(autoload 'jedi:setup "jedi" nil t)
;;(add-hook 'python-mode-hook 'jedi:setup)
;;(setq jedi:complete-on-dot t)                 ; optional
(elpy-use-ipython)
(global-eldoc-mode -1)

(add-hook 'after-init-hook 'global-company-mode)
;;(defun my/python-mode-hook ()
 ;; (add-to-list 'company-backends 'company-jedi))
;;(add-hook 'python-mode-hook 'my/python-mode-hook)
  • Welcome to Emacs.SE! It is unlikely that people will want to scroll through your entire init file, so please remove the parts that are not related to python and/or autocomplete. – Dan Dec 20 '16 at 22:29
1

You're seeing two popups because you've enabled two different auto-completion systems at the same time. Elpy activates company-mode, jedi.el activates auto-complete-mode. I'd suggest removing jedi.el from your config as Elpy handles that part already.

  • So I delete jedi, but it is still the same. I don't think it is related to jedi, since in my init.el, I comment all things related to jedi. – Zimou Zhang Dec 20 '16 at 23:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.