8

I tried to get the "capture"-Feature to work.

I did the following things:

  • Installation of the newest Version of the Org mode (now the version 8.2.10)
  • To get the capture feature work i added to my .emacs:
;;https://stackoverflow.com/questions/3622603/org-mode-setup-problem-when-trying-to-use-capture

;(add-to-list 'load-path "/nils/home/emacs.d/org-7.01h/lisp")

(require 'org-install)

(require 'org) ;; maybe this line is redundant

;; Verzeichnis für "org-capture" festlegen
 (setq org-default-notes-file (concat org-directory "/notes.org"))

(define-key global-map "\C-cc" 'org-capture)

After these changes i get the error message
Symbol's function definition is void: org-link-types
when I open a .org file.

I don't know how to handle this error message.

6
  • 2
    You get this error because org-link-types is a variable in orgmode 8.2.10 and not a function. But, from this search it looks like this symbol has a function definition in newer versions of orgmode (version 9.x). Maybe, you mixed different versions of orgmode?
    – Tobias
    Dec 21, 2016 at 9:59
  • Yes, this is possible.
    – tester
    Dec 21, 2016 at 10:05
  • Directly after the installation emacs told me, that the version of org-mode ist 9.0.2, now it tells me it's the version 8.2.10.
    – tester
    Dec 21, 2016 at 10:08
  • 1
    So you should get rid of one of these versions. It may be that one of these versions comes from the package manager of yor system (e.g. apt-get under linux) and the other one from elpa or melpa (these are found unter ~/.emacs.d/elpa/org-20161017/).
    – Tobias
    Dec 21, 2016 at 10:25
  • 3
    Are you using Spacemacs ? In version 0.200.7 "org layer" seems to be causing such version conflicts in org-mode. I found a related issue here , and proposed a solution with a patch (also in PR #8399).
    – RockyRoad
    Feb 18, 2017 at 19:55

1 Answer 1

3

I solved the problems with uninstall all org-packages in elpa. Now the my .org files open without the error and the links work fine.

Thanks to Tobias for his hints!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.