Swiper creates a minibuffer many lines in height. This height is borrowed equally from my existing, vertically-arranged, windows. When Swiper is dismissed, this space is recovered by the windows and they all grow slightly, moving down the screen as they do so.

The consequence of this is that the text that I've just searched for jumps down the screen. I find this jarring, and would like to prevent it from happening. Any ideas?

The documentation suggests that setting window-combination-resize to nil should do what I want, but this is already set to nil; it seems that either this doesn't apply to minibuffers, or something is preventing it from taking effect in this case.

  • 1
    I don't know how to stop the line that you've just searched for moving, but you might find that using global-hl-line-mode helps you not lose track of line as it moves.
    – stevoooo
    Jan 4 '17 at 12:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.