3

I'm using GNU Emacs 24.5.1 (GUI version) on Mac OS X 10.11.1 with Evil mode and installed evil-surround through the built-in package manager of Emacs.

Now, I can add all surroundings, for example, surround a word by / with viwS/.

However, changing and deleting surroundings works only with certain types of surroundings, for example, ", ', ), ], but not with /, *, = (which are used in org-mode).

If I move the cursor, for example, on the text /word/, and type ds/, then after typing ds the word delete appears in the minibuffer, but then upon typing / the minibuffer is emptied, but nothing changes in the surrounded word, i.e. the / are still there.

Does anyone know how to fix this, i.e. allow surroundings like /, *, = to work properly?

  • I generally consider Stackexchange the wrong place for bug reports, with the exception of projects that decided to use it as their user support "forum". – wasamasa Jan 7 '17 at 15:06
3

Installing the packages embrace and evil-embrace fixes the problem. After that you must define new pairs with embrace. I have

(use-package embrace
    :ensure embrace)
(use-package evil-embrace
    :ensure evil-embrace)
(evil-embrace-enable-evil-surround-integration)
(setq evil-embrace-show-help-p nil)
(add-hook 'LaTeX-mode-hook
    (lambda ()
        (embrace-add-pair ?a "`" "'")
        (embrace-add-pair ?e "\\emph{" "}")))
  • 1
    Great. To add the common org-mode surrounding pairs to org-mode, it's enough to add the line (add-hook 'org-mode-hook 'embrace-org-mode-hook). – weibeld Jan 24 '17 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.