4

shot-1

I'm using a dark theme, so it's a bit hard to see, but there is a black line between the modeline and the echo area in the shot above. You can also see it between the modeline and a hydra, and the hydra and the echo area below.

shot-2

Any idea what this is, so I can get rid of it if possible?

  • Could you please tell me about the font in the screenshots ? – stackunderflow Jan 8 '17 at 15:11
  • @displayname Sure, it's a free Mozilla font called Fira Mono. If you're using an editor that supports OpenType features (not Emacs, unfortunately), there's a modified version called Fira Code that includes programming ligatures. – rjww Jan 8 '17 at 23:55
3

Since you're using my Emacs theme and could be using my emacs.d config, I suspect you have window-divider-mode enabled, which adds this border. You can either:

  • Set the bottom border's width to 0: (setq window-divider-default-bottom-width 0)
  • Turn off the bottom border: (setq window-divider-default-places 'right-only)
  • or turn off window-divider-mode altogether: (window-divider-mode -1)

For reference, here is my window-divider-mode config, taken from core/core-ui.el :

;; `window-divider-mode' gives us finer control over the border between windows.
;; The native border "consumes" a pixel of the left fringe on righter-most splits
;; (in Yamamoto's emacs-mac at least), window-divider does not.
;; NOTE Only available on Emacs 25.1+
(when (boundp 'window-divider-mode)
  (setq window-divider-default-places t
        window-divider-default-bottom-width 1
        window-divider-default-right-width 1)
  (window-divider-mode +1))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.