2

Since upgrading to Emacs 24.5.1 and org-mode 8.3.3 (Kubuntu 16.04), I can no longer export org-mode files as ODT; only as iCal, HTML, LaTeX, or plain text. Is that normal? Is there a way to get ODT export back?

  • 1
    Maybe you could try org-plus-contrib ? – Chakravarthy Raghunandan Jan 9 '17 at 16:05
  • Great, that works! Pity that it's not installed by default in Kubuntu now, since ODT export was available in 14.04. – Supernormal Jan 9 '17 at 17:25
  • I can accept your answer if you make it an answer instead of a comment. – Supernormal Jan 10 '17 at 20:40
  • 1
    if odt export already existed in older versions of Org, then probably it was just disabled by default in 8.3.3 Org version. I do not know since I haven't used odt export and am using the latest version of Org. But I guess my initial comment was unnecessary. You just had to enable export to ODT in options. But hey, at least you got the latest version of Org now :) Shall I add this comment as an answer? – Chakravarthy Raghunandan Jan 11 '17 at 3:46
  • Yes -- I guess the answer, then, is to customize "Org Export Backends". Thanks for pointing that out. – Supernormal Jan 11 '17 at 11:59
3

You can enable the ODT backend by adding this line to your init.el file:

(eval-after-load "org" '(require 'ox-odt nil t))

I know that this answer is rather late, but I hope this will help someone in the future.

1

Expanding on a comment by @Supernormal, I have org-export-backends customised as

(setq org-export-backends '(ascii html latex odt))

thus disabling a backend I will not use, ical, which unclutters the dispatcher screen - and adding the ones I need, namely odt

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.