0

I am aware of the syntax for creating repeated tasks in org-mode, but for some reason I am now unable to manually edit the text of the "Scheduled" and "Deadline" date fields to do this, unless I do the workaround described below:

Example date field as it appears in my org-buffer: **** TODO [#B] Order kitty litter DEADLINE: <2017-02-07>

Example date field as copied and pasted: **** TODO [#B] Order kitty litter DEADLINE: <2017-02-07 Tue + = >

If I place the point before the closing angle bracket, as I would normally do to add repeating-event syntax, I cannot type. The only way I can edit this date field manually is if I first move the point to the opening angle bracket and destroy the syntax by adding a random character, e.g. <a2017-02-07., which turns the filed into plain text. I can then move the point to the closing bracket, add the repeat syntax, and then remove the character I inserted to make it editable. But this is not behavior I have encountered before, so something must have changed in my config.

Can anyone point me to a config variable or other problem that might be the culprit? For example, where is that hidden + = text before the closing bracket coming from?

  • Perhaps it is a major-mode or minor-mode keyboard shortcut that is being activated and you think it should be normal movement, but it is something special relating to org-mode. Type C-h k and then do your movement that is problematic and see if it is actually a special org-mode function that gets activated or something normal. Once you find out what function is being called, then you can deactivate that behavior or change it . . . There is a special feature to overlay timestamps with a more eye catching appearance (perhaps that's it?): orgmode.org/manual/Custom-time-format.html – lawlist Jan 23 '17 at 7:41
  • Do you have custom timestamps enabled? – Juancho Jan 23 '17 at 17:18
2

Have you enabled org-toggle-time-stamp-overlays via C-c C-x C-t?

With this enabled you cannot place the cursor onto a timestamp anymore, only before or after.

  • This must have been it; I didn't enable it intentionally, but it may have showed up in one of the configurations I've borrowed from. – WordBrewery Mar 11 '17 at 23:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.