0

I was using emacs-ipython-notebook for data visualisation for some days.But then I started getting the error -ein failed to login to 8888.I checked my ipyhton notebook server and it's running on default port 8888 and I also tried to change the port number and login again but failed.I tried ein:dev-bug-report-template and here goes my system info

## System info:

```cl
("EIN system info"
 :emacs-version
 "GNU Emacs 24.3.1 (x86_64-pc-linux-gnu, GTK+ Version 3.10.7)
 of 2014-03-07 on lamiak, modified by Debian"
 :emacs-bzr-version nil
 :window-system x
 :emacs-variant nil
 :os
 (:uname
  "Linux jamesbondu-HP-Pavilion-g6-Notebook-PC 4.2.0-41-generic #48~14.04.1-Ubuntu SMP Fri Jun 24 17:09:15 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
"
  :lsb-release
  "No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.4 LTS
Release:    14.04
Codename:   trusty
")
 :image-types
 (svg imagemagick png gif tiff jpeg xpm xbm pbm postscript)
 :image-types-available
 (svg imagemagick png gif tiff jpeg xpm xbm pbm postscript)
 :request
 (:backend curl)
 :ein
 (:version "0.12.1"
       :source-dir "/home/jamesbondu/.emacs.d/elpa/ein-20170119.927/")
 :lib
 ((:name "websocket"
     :path "~/.emacs.d/elpa/websocket-20161113.1736/websocket.elc"
     :featurep t
     :version-var websocket-version
     :version "1.5")
  (:name "request"
     :path "~/.emacs.d/elpa/request-20161221.1711/request.elc"
     :featurep t
     :version-var request-version
     :version "0.2.0")
  (:name "popup"
     :path "~/.emacs.d/elpa/popup-20160709.729/popup.el"
     :featurep nil
     :version-var nil
     :version nil)
  (:name "python"
     :path "/usr/share/emacs/24.3/lisp/progmodes/python.elc"
     :featurep t
     :version-var nil
     :version nil)))
```

Can anyone help me with this?

1
"GNU Emacs 24.3.1 (x86_64-pc-linux-gnu, GTK+ Version 3.10.7)

EIN only works on Emacs 25. See https://github.com/millejoh/emacs-ipython-notebook/issues/190.

If perchance you use a Ubuntu derivative, there is a ppa:

sudo add-apt-repository ppa:kelleyk/emacs
0

I was experimenting similar issues and it was solved by step three in EIN guide to solve problems. Have you tried it?

[  ] I read "Avoid standard Emacs traps" section in
https://github.com/tkf/emacs-ipython-notebook/blob/master/CONTRIBUTING.md
[  ] I checked that IPython works with the browser interface.
[  ] I checked that the problem was not due to badly compiled
files. Removing *.elc files from source directory of EIN and
its dependencies did not solve the problem.
[  ] I checked that the libraries are loaded from intended place.
(You can check the location in the "System info" section below)
0

I ran into this problem and found that the issue was with the token that jupyter notebooks now use. I disabled the token per this GitHub issue. I'm reproducing the instructions below:

cd ~/.jupyter
jupyter notebook --generate-config

Then set the c.NotebookApp.token parameter to an empty string 

c.NotebookApp.token = ''

Note that if you care about security, this is not recommended. Instead you should be able to enter the token into EIN.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.