4

In my init file, I have C-) bound to a smartparens "slurp" command. This works great on linux, but when I try to use the same keybinding on my Windows machine, nothing happens.

To troubleshoot on my Windows machine, I've tried C-h c followed by C-)—emacs doesn't register that any keys have been hit.

I've tried a couple of similar key sequences: M-) and C-0 both register fine.

Any idea why C-) doesn't register, and any idea how to fix it?

  • First, does it happen with no init file (emacs -Q)? Second, does windows use C-) for something else, which prevents it from reaching emacs? – Dan Jan 28 '17 at 0:21
  • Are you using the GUI version of emacs? – DoMiNeLa10 Jan 28 '17 at 0:34
  • @Dan, it happens with no init file. I looked at a page of windows shortcuts here, and C-) isn't on the list. – tcelferact Jan 28 '17 at 1:00
  • @DoMiNeLa10, yes I'm using the GUI version. – tcelferact Jan 28 '17 at 1:01
  • Please show your code that binds the key sequence. Provide a step-by-step recipe that starts from emacs -Q (no init file). – Drew Jan 28 '17 at 1:33
4

I found a solution—the following works for me:
Control Panel >
Language >
Advanced Settings >
Change language bar hot keys >
Ensure Between input languages is highlighted >
Change Key Sequence... >
Change Switch Keyboard Layout from Ctrl + Shift to Not Assigned.

A similar process is outlined here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.