LaTeX preview with C-c C-x C-l looks very tiny on my HiDPI screen. What can I do to solve this?enter image description here

2 Answers 2


The variable preview-scale-function in the preview-appearance group controls this. From the customization menu:

Preview Scale Function: [Value Menu] preview-scale-from-face
Calculate preview scale from ‘preview-reference-face’.
This calculates the scale of EPS images from a document assumed to have a default font size given by function ‘preview-document-pt’ so that they match the reference face in height.

Scale factor for included previews.
This can be either a function to calculate the scale, or a fixed number.

Try setting the value to various fixed numbers. The preview sizes should shift up or down accordingly.

  • strange, tried to look it up on customize but it says there's nothing matching it... Commented Feb 1, 2017 at 8:23
  • It won't show up in customise until after preview-latex is loaded. You might have to open a .Tex file or make a preview first, then customize-variable
    – Tyler
    Commented Feb 1, 2017 at 12:16

In order to see the rendered LaTeX equations scaled

#+BEGIN_SRC emacs-lisp
(setq org-format-latex-options (plist-put org-format-latex-options :scale 1.4))

The scale 1.4 is Ok in my setup... try it, and change the number to fit your needs.

  • 1
    I think the question was asking about LaTeX files, not LaTeX blocks in org files.
    – Tyler
    Commented Feb 1, 2017 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.