2

the org-mode-ndays setting stopped having any effect on my agenda view after updating all packages. I would like to get this working again. :) When I open the agenda the Week-agenda is shown (should be day-agenda), if I change it to day-agenda and then refresh I'm back in Week-agenda. This is really annoying but I have no idea how to investigate this issue. Any suggestions?

my setup

  (setq org-agenda-custom-commands
        '(("d" "Daily agenda and all TODOs"
           (
            (agenda ""
                    ((org-agenda-ndays 1)
                     (org-agenda-skip-function '(org-agenda-skip-entry-if 'nottodo 'any))))
            )
       )))

GNU Emacs 25.1.1 (x86_64-unknown-linux-gnu, GTK+ Version 3.10.8) of 2016-10-20

Org mode version 9.0.4 (9.0.4-elpaplus @ /home/ibayer/.emacs.d/elpa/org-plus-contrib-20170124/)

2

The new setting is called org-agenda-span. Try:

(setq org-agenda-span 'day)
  • 1
    Awesome, thanks a lot. I spend quite some time trying to figure out what went wrong. – user14419 Feb 6 '17 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.