5

When I write a long line while composing a mail in mu4e, the lines are truncated for viewing (toggle-truncate-lines), but as soon as I hit Enter fixed line breaks (column width seems to be 70 or something) are introduced.

How can I stop mu4e from introducing these line breaks?

5

You can turn off auto-fill-mode in the mu4e message buffer. You can do so automatically by adding a function to the mu4e-compose-mode-hook:

(defun no-auto-fill ()
  "Turn off auto-fill-mode."
  (auto-fill-mode -1))

(add-hook 'mu4e-compose-mode-hook #'no-auto-fill)
| improve this answer | |
3

This will suffice in emacs nowadays:

(add-hook 'mu4e-compose-mode-hook 'turn-off-auto-fill)
| improve this answer | |
  • 1
    I like to combine this with (add-hook 'mu4e-compose-mode-hook 'visual-line-mode) to have 'soft' line wrapping without actual newlines, but ensuting that the text stays inside my frame. – AstroFloyd May 20 '19 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.