0

FWIW, I'm on Mac OS X running this with emacs -Q:

GNU Emacs 25.1.1 (x86_64-apple-darwin15.6.0, NS appkit-1404.47 Version 10.11.6 (Build 15G1108)) of 2016-11-11

If I click the little "maximize" button I get a frame with the (fullscreen . fullboth) parameter. According to ancient tradition, let us all praise Emacs' distinctive naming conventions.

From a maximized frame, I cannot get (make-frame) to create a non-maximized frame. I've tried setting the fullscreen, height, and width options of default-frame-alist, and I've tried passing various combinations of the same into the make-frame function. No joy.

What am I missing?

  • Show your code. The question is unclear so far. make-frame is to create a new frame, not to resize an existing frame. Are you saying that if you have one frame maximized you cannot create another (using make-frame)? Are you sure a frame was not created behind your maximized one? (Try raise-frame for it, if that's the case.) – Drew Feb 28 '17 at 23:32
  • Not really any code to show. From a terminal, emacs -Q. Click the button that maximizes the frame. Then, in the scratch buffer, (make-frame) C-x C-e. It creates a new frame, but the new frame is also maximized. I'm seeking what options I need to pass in to the (make-frame) function to get a new frame that is NOT also maximized – purple_arrows Feb 28 '17 at 23:35
  • 1
    I am not able to reproduce this with Emacs 25.1.1 downloaded from emacsformacosx.com (built September 17, 2016). Without any user configuration, I launch Emacs.app on OSX 10.6.8. I click on the green button twice -- once to make it the full length of the frame, and a second time to make it the full width of the frame. I kill the *GNU Emacs* with Command-k, I type (make-frame) in the *scratch* buffer and type C-x C-e. The new frame is the default small size in the upper-left corner of the screen. – lawlist Mar 1 '17 at 1:39
  • On OSX 10.11.6, I change the recipe slightly and call M-x toggle-frame-maximized and get the same result as my previous comment by using the same steps (except for no green button pressing in this example). On 10.11.6, the green button makes the frame full screen, not just maximized. – lawlist Mar 1 '17 at 1:40
  • 1
    If, however, on 10.11.6, I hit the green button and make it full screen, then I get the same result as the original poster -- i.e., the new frame is also full screen (probably because I'm in full-screen mode, which seems like the behavior I would expect, although I've only thought about it for a few minutes). – lawlist Mar 1 '17 at 1:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.