1

When using the fill-column-indicator package with org mode, I get wrong argument errors when exiting the source block editing window, issues with utf-8 character artefacts in source blocks exported to html and some other minor quirks. How can you fix this?

Current emacs 25.1 and org-mode 9.0.5

  • 2
    fci-mode is a nightmare. It causes issues with way too many other modes. I would recommend just using whitespace-mode instead. I've never had any problems with it. – Qudit Mar 26 '18 at 20:42
1

This is a known issue with org-mode and fci-mode. See here and here for a discussion and some suggested solutions. Personally, I found the cure to be worse than the symptom and it didn't quite fit with what I wanted.

I have instead found an alternative which works with org-mode and still provides me with the sort of information I was after with fci-mode. I found it was trivial to get similar functionality with whitespace-mode. Rather than a vertical line indicating the fill column, a face is used to colour all characters past the fill line with a different colour.

  (use-package whitespace-cleanup-mode
    :ensure t
    :diminish whitespace-cleanup-mode
    :init
    (setq whitespace-cleanup-mode-only-if-initially-clean nil
          whitespace-line-column 80
          whitespace-style '(face lines-tail))
    :config
    (global-whitespace-mode)
    (global-whitespace-cleanup-mode))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.