3

When I type any text in docstring I've got an exception right at cursor place. May be it's some python-mode.el addon, I don't know. How should I fix it? enter image description here

I use company-jedi and python-mode.el.

  • Please file a bug-report at gitlab.com/python-mode-devs/python-mode/issues giving some plain code triggering the bug. – Andreas Röhler Mar 5 '17 at 13:22
  • OK. But what is this? If this is some completion, how can I turn it off? – sivakov512 Mar 5 '17 at 15:22
  • Does it happen when you start Emacs without your init file (emacs -Q)? If not, recursively bisect your init file until you isolate the code that causes the problem. – Dan Mar 5 '17 at 21:31
  • did you find a solution to this problem? – Mike Vella Mar 28 '17 at 16:43
1

I had this same problem and for me the problem was caused by python-mode. Removing python-mode and falling back on the emacs-25 default (python.el) solved the problem.

|improve this answer|||||
  • I don't use jedi-mode, only company-jedi and jedi-core (as dependency of company-jedi) – sivakov512 Mar 29 '17 at 1:35
  • I deleted python-mode and now I have no problems =) – sivakov512 Mar 29 '17 at 1:36
  • 1
    @CryptoManiac I was about to come on here and say the same thing! After I commented here I realised that the problem was still there. I deleted python-mode and now it works fine again. – Mike Vella Mar 29 '17 at 14:29
  • I'm don't understand you) You don't use python-mode now? – sivakov512 Mar 30 '17 at 14:37
  • that's correct. I deleted python-mode – Mike Vella Mar 30 '17 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.