This question already has an answer here:

Using Rust/Racer/Eldoc is causing performance problems while navigating around the file (hanging while eldoc is fetching the docs).

Running eldoc-mode reports that it's disabled but still runs Racer's eldoc function.

Is there a way to globally disable eldoc?

marked as duplicate by Drew, zck, Dan Mar 13 '17 at 15:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 3 down vote accepted

Since Emacs 25.1 a new global minor mode global-eldoc-mode exists, and is enabled by default.

To disable it, simply add this to your init file:

(global-eldoc-mode -1)

You can alternatively (setq-local eldoc-documentation-function #'ignore) in buffers for which you wish eldoc to have no effect, without disabling it elsewhere.

Not the answer you're looking for? Browse other questions tagged or ask your own question.