3

It seems to me that org-capture requires templates to start with a heading (*). Can I not have a template like:

("d" "Daily Tasks" entry (file+datetree+prompt "daily.org")
     "- [ ] %?")

that does not start with a *.

4

You have to change the third element the template ("entry type"). From the help:

type         The type of entry.  Valid types are:
               entry       an Org node, with a headline.  Will be filed
                           as the child of the target entry or as a
                           top-level entry.
               item        a plain list item, will be placed in the
                           first plain list at the target
                           location.
               checkitem   a checkbox item.  This differs from the
                           plain list item only is so far as it uses a
                           different default template.
               table-line  a new line in the first table at target location.
               plain       text to be inserted as it is.

For a checkbox you want checkitem instead of entry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.