1

I recently setup mu4e. My Setup : emacs25, mu 0.9.18, macOS Sierra

I used mbsync to download my emails.

When I do M-x mu4e, I get error error in process sentinel: Database empty; try indexing some messages

But I have :)

I checked mu4e-maildir. It is correct (which is where mbsync has downloaded the messages.)

mu index (as well as mu index --maildir=~/Maildir just in case) also worked well.

I can use mu find <pattern> successfully.

But mu4e can't seem to find the DB

I think this is some configuration mismatch.

How do I troubleshoot this ?


References :

  • What's the value of these variables mu4e-maildir, mu4e-trash-folder, mu4e-refile-folder, mu4e-sent-folder, mu4e-drafts-folder? – nasser alshammari Jun 11 '17 at 12:08
  • @nasseralshammari See my answer. The problem above was (possibly) caused due to my non-standard setup – Mandar Vaze Jul 4 '17 at 7:45
0

I came back to the setup after almost 3 months. I enabled mu4e in my .spacemacs and uncommented all the other settings related to mu4e, and what do you know? It works !!

Off course, I'm not saying this is magic.

But I have a hypothesis.

Some time ago, I had moved all the spacemacs setup into ~/spacemacs and I used to start the emacs as HOME=~/spacemacs emac &

I think this used to throw off a lot of software. I used to ran into "unexplained" behavior, where "normal" troubleshooting doesn't help.

So last week, I moved off that setup, and now my .spacemacs and .emacs.d etc all are in my actual HOME (i.e. ~) like everyone else.

I think this alone has solved several problems.

mu4e may be one of those.


I now start emacs from the dashboard using the icon (macOS) - which earlier I couldn't do, since I didn't know how to set different HOME when launching from the dashboard. So I was forced to always use the term (I'm not complaining. Just sayin)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.