1

My package depends upon org 9. I want to use cask to enforce this dependency.

The way to specify this in my cask file would seem to be (depends-on "org" "9.0.1") as documented here.

However cask seems to be ignoring the version specified. The following is some sample output demonstrating this.

> cat Cask && cask install && cask update && cask eval "(progn (require 'org) (message (org-version)))" && cask --version && emacs -q --eval "(progn (require 'org) (message (org-version)))" --batch
(source gnu)
(source melpa)

(package "org-db-link" "0.1.0" "Quickly navigate and search your emacs org trees")
(files "org-db-link.el")

(depends-on "org" "9.0.1")
8.2.10
0.8.1
Loading 00debian-vars...
Loading /etc/emacs/site-start.d/50autoconf.el (source)...

Loading /etc/emacs/site-start.d/50dictionaries-common.el (source)...
Loading debian-ispell...
Loading /var/cache/dictionaries-common/emacsen-ispell-default.el (source)...
Loading /var/cache/dictionaries-common/emacsen-ispell-dicts.el (source)...
Loading /etc/emacs/site-start.d/50ecasound-el.el (source)...
Loading /etc/emacs/site-start.d/50festival.el (source)...
Loading /etc/emacs/site-start.d/50pylint.el (source)...
Loading /etc/emacs/site-start.d/50python-docutils.el (source)...
Loading /etc/emacs/site-start.d/50texlive-lang-english.el (source)...

8.2.10

```

I have tried running cask upgrade but this did not help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.