2

There are two buffers in image-dired, one is the thumbnail buffer *image-dired*, the other is the displayed image buffer *image-dired-display-image*.

When I type return on an image thumbnail, the focus is switched to the displayed image buffer.

Is there a setting that will make the focus stay in the thumbnail buffer? What about making the displayed image buffer follow the focus in the thumbnail buffer without hitting return?

Edit: Turns out the culprit is shackle. If you use it, the default behaviour is restored with:

(setq shackle-rules
'(("\\`\\*image-dired.*?\\*\\'" :regexp t :select nil)
  (image-dired-thumbnail-mode :select nil)
  (image-dired-image-display-mode :select nil))
  shackle-default-rule '(:select t))
3

When I type return on an image thumbnail, the focus is switched to the displayed image buffer. Is there a setting that will make the focus stay in the thumbnail buffer?

What you're asking for is the default behaviour so far as I can see (when running image-dired in both emacs 24.5 and 25.2). You should be able to confirm that by running emacs -Q.

What about making the displayed image buffer follow the focus in the thumbnail buffer without hitting return?

If you just want to cycle through the images, then:

  • SPC runs the command image-dired-display-next-thumbnail-original
  • DEL (translated from <backspace> in my case) runs the command image-dired-display-previous-thumbnail-original

As always, use C-hm to view help on the modes and keybindings for the current buffer.


When I run image-dired in a dired buffer, all files are marked, how to disable that behavior and mark the files in the thumbnail view manually?

Mark the files in dired and call M-x image-dired-display-thumbs instead of image-dired

That command is bound to C-td by default.

Type C-tC-h in a dired buffer to see other image/thumbnail-related bindings under that same prefix.

  • When I run image-dired in a dired buffer, all files are marked, how to disable that behavior and mark the files in the thumbnail view manually? – godblessfq Mar 23 '17 at 7:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.