1

There is a large blank space between the top of the buffer and the bottom of the menu-bar in my Emacs 24 on Ubunutu 16.10 that doesn't want to go away. I've tried Googling but can't really find anything to help, would appreciate some ideas! Screenshot included:

enter image description here

  • 3
    What you mean with toolbar is actually the menu-bar. I think the large blank space is the real tool-bar but maybe your emacs is missing the icons for the tool-bar. You can test whether the large blank space is the tool-bar by switching off Options -> Show/Hide -> Tool-bar. – Tobias Mar 30 '17 at 10:26
  • Hah. You are right. (tool-bar-mode -1) is now in my init.el. Thank you. – KHekkus Mar 30 '17 at 11:05
  • 1
    @Tobias: Please consider posting that as an answer, which can then be accepted by OP. – Drew Mar 30 '17 at 14:44
0

For marking this question as done I cite my comment below the question as an answer here:

What you mean with toolbar is actually the menu-bar. I think the large blank space is the real tool-bar but maybe your emacs is missing the icons for the tool-bar. You can test whether the large blank space is the tool-bar by switching off Options -> Show/Hide -> Tool-bar

The original poster added that the assumption from the comment is right and that he switches the tool-bar off by adding (tool-bar-mode -1) to his init file.

The remaining question would be why the tool-bar remains empty. This is an error. There should be at least buttons for find-file, menu-find-file-existing, dired, kill-buffer, and some more buttons for editing text.

Update: Note, that this is a known problem with emacs24 under Ubuntu 16.10. There already exists a bug report with a workaround for it at launchpad.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.