3

I'm trying to upgrade org in my setup by following the instructions here but I don't see org listed as an option. The instructions say to report it as a discrepancy but I'm thinking it's more likely something on my end since I haven't seen it there for a while and figure someone else would have reported by now.

I'm on Windows with Emacs 25.1.1. I've tried emacs -q then package-refresh-contents and can see the other packages listed at http://elpa.gnu.org/packages/ but not org.

4
  1. Open emacs in the default fundamental mode (not in an org file).
  2. Run M-x package-refresh
  3. Run M-x package-install RET org followed by spacebar then RET.

The extra space at the end of org was essential in my case.

In my vanilla emacs install, package-install wanted to offer autocorrect for the org-edna and orgalist packages, so the spacebar was required to get emacs to move past those and recognize the entry for the plain-old org package.

1

Orgmode is such a large project that it has its own repo.

See this discussion on /r/emacs about installing a new version of Orgmode using use-package.

  • I added that repo as well and still don't have the option of org using package-install however I do have the option of org-plus-contrib. I also checked list-packages and can see two org entries, one from gnu and one from the org repo. – kfoley Mar 31 '17 at 20:34
  • Can you not install the version from the org repo by hitting i, then x in the package menu? – Tianxiang Xiong Mar 31 '17 at 20:40
  • I'm able to install by doing that, I don't get why it doesn't show up in package-install. This is also causing errors because I'd like to add org to my init file using use-package – kfoley Mar 31 '17 at 21:01
  • R.e. use-package, see the /r/emacs thread I linked to. Apparently (use-package org :ensure org-plus-contrib :pin org) should work; haven't tried it myself. – Tianxiang Xiong Mar 31 '17 at 21:15
  • 3
    package-install only works for packages that aren't already installed. org mode is installed by default, so it will never show up for package-install. You can upgrade it to a newer version via package-list-packages. – Tyler Apr 26 '18 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.