1

I'm trying to get started using Icicles, but I'm wondering if ido is interfering with functionality. So far:

  1. I installed Icicles from the repo and added

    (require 'icicles)
    

    to init.el.

  2. I used M-x customize to turn off ido, resulting in

    '(ido-mode nil nil (ido))
    

    in the custom-set-variables section of init.el.

  3. Restarted Emacs.

Now, running C-h c C-x C-f gives me the result of

C-x C-f runs the command ido-find-file

However, the EmacsWiki page on Icicles says this command should have been automatically remapped to icicle-file. There are some other functions that also don't seem to be working. By contrast, though, C-h c M-x results in

M-x runs the command icicle-execute-extended-command

How do I fix this?

6
  • 1
    Try starting from emacs -Q and loading Icicles. If C-x C-f is bound to ido-find-file then you clearly have not removed Ido from the equation. And maybe try using the Customize UI, instead of fiddling with code in your init file.
    – Drew
    Commented Nov 6, 2014 at 21:57
  • And I don't think you found anything in the Icicles doc (including on Emacs Wiki) about ido-find-file being remapped to icicle-file.
    – Drew
    Commented Nov 6, 2014 at 21:59
  • This is the Icicles doc page that speaks about Ido.
    – Drew
    Commented Nov 6, 2014 at 22:02
  • And this is the Icicles doc page about Icomplete (icomplete-mode), if you want some Ido-like behavior with Icicles.
    – Drew
    Commented Nov 6, 2014 at 22:24
  • I restarted with emacs -Q and turned on icy-mode and found that C-x C-f was now bound to icicle-file so I guess ido is still somehow not fully disabled, as you suspected. Here's the page I was referencing, which contains this: "...command find-file, is by default remapped in Icicle mode to multi-command icicle-file. Remapping means that any keys, such as C-x C-f, that would normally be bound to find-file are instead bound to icicle-file when you are in Icicle mode." Commented Nov 7, 2014 at 3:34

1 Answer 1

1

Starting with emacs -Q and manually entering icicle-mode solved the problem, so it turned out that ido was still active despite my attempts to disable it through the customize interface.

On a newbie hunch I opened my init.el, added

(ido-mode nil)

and restarted emacs. This worked. Now C-x C-f is bound to icicle-file and other functionality seems normal.

1
  • That sounds right. The best way to turn off something like Ido (or Icicles) is to use its mode command: ido-mode for Ido, icicle-mode for Icicles.
    – Drew
    Commented Nov 7, 2014 at 4:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.